Diseazd

FutoFab CV axles

    Recommended Posts

    I just ordered a pair of FutoFab CV axles for my green R180 diff Z. Anyone install a set of these? If so, any words of wisdom on your installation would be much appreciated. 

    Thanks

    Guy

    Share this post


    Link to post
    Share on other sites

    Well here they are..........  Doesn’t look too difficult. I’ll take some pics of the installation.....maybe the Stroker motor won’t hurt these babies!

    65083688-B208-4FFA-9876-A8CD1C94FFED.jpeg

    • Like 4

    Share this post


    Link to post
    Share on other sites

    I might be wrong - but get ready for some clunking in the rear. There seems to be excessive radial movement in the joint - slop. Supposedly these axles were engineered more specifically for 4wd vehicles. I’m not going to pretend I’m an engineer , but there are some unhappy folks with these. Now I’ve put them thru some serious stress testing , but my HP isn’t to your level. Just today I was under the car cleaning and inspecting and couldn’t find see anything wrong . 

    Initially when I bought these the instructions were okay, but had the wrong torque value on the Allen bolts and I stripped one. After a phone call I got it straightened out. Safety wiring is a bitch .

    Share this post


    Link to post
    Share on other sites

    Thanks Madkaw.....I feel much better LOL. I’ll keep everyone posted with how they perform. I have a friend that installed these in a 510. He loved em.

    Share this post


    Link to post
    Share on other sites

    Thanks Mike. I guess a can of black paint will make color choice an option. 

    Share this post


    Link to post
    Share on other sites

    Apples to oranges - I have the Subby STI diff, so that might things different for me as far as noises. The design might have also evolved to something different also.

     

    Share this post


    Link to post
    Share on other sites

    Guy, your original halfshafts appear to be in really good condition. Were they exhibiting any symptoms?

    Share this post


    Link to post
    Share on other sites

    Yes Charles, there was excessive play in the driver side half shaft outside u joint.

    Edited by Diseazd
    • Like 1

    Share this post


    Link to post
    Share on other sites

    All finished. Took it for a test drive and it works perfect. No noise, no slack.....solid. Even when I let off and nail it, no play......I’m happy with Futofab CV shafts!

    2D4E9049-1452-4FC0-BE44-84487B59ADBB.jpeg

    Edited by Diseazd
    • Like 3

    Share this post


    Link to post
    Share on other sites

    What diff do you have ?

     

    And did safety wire the bolts?

    Edited by madkaw

    Share this post


    Link to post
    Share on other sites

    40 minutes ago, grannyknot said:

    R200 3.90 with an OBX limited slip, so far it is running great.

    Did you do the mods on the OBX?

    Share this post


    Link to post
    Share on other sites

    Very cool .......what’s the feedback on those? Do they come pre greased? Do you know anyone that has used em?

     

    Share this post


    Link to post
    Share on other sites

    9 hours ago, Patcon said:

    Did you do the mods on the OBX?

    Oh yeah,  they are not really useable without new spring washers. Apparently OBX isn't selling them anymore so glad I got one before they disappeared.

    42 minutes ago, Diseazd said:

    Very cool .......what’s the feedback on those? Do they come pre greased? Do you know anyone that has used em?

    They look like a good alternative for a stock half shafts but with a 225 ft/lb torque limit they are not going to handle what your new Futofab axles will.

    Share this post


    Link to post
    Share on other sites
    2 hours ago, grannyknot said:

    Oh yeah,  they are not really useable without new spring washers. Apparently OBX isn't selling them anymore so glad I got one before they disappeared.

    They look like a good alternative for a stock half shafts but with a 225 ft/lb torque limit they are not going to handle what your new Futofab axles will.

    Hadn't heard that. Too bad...

    Share this post


    Link to post
    Share on other sites

    I have a set on my 510. Work perfect. I have the STI diff stub version. 

    I'll let my old Futofab axles go for cheap. Hate them. 

    Edited by zKars

    Share this post


    Link to post
    Share on other sites
    I have a set on my 510. Work perfect. I have the STI diff stub version. 
    I'll let my old Futofab axles go for cheap. Hate them. 

    Let’s talk...

    Share this post


    Link to post
    Share on other sites

    Just put another 50 miles on mine.....zero complaints. What does yours do Jim?

    Share this post


    Link to post
    Share on other sites

    8 hours ago, zKars said:

    I have a set on my 510. Work perfect. I have the STI diff stub version. 

    I'll let my old Futofab axles go for cheap. Hate them. 

    Would you elaborate?

    Share this post


    Link to post
    Share on other sites
    6 hours ago, madkaw said:

    Would you elaborate?

    on the axle price, say $300? $900 new but given the recent bad press I can seem to give them away.

    on the datsunrestomod axles, I bought the version that have the snapin Subby stubs that are part of their CV axles. No need for another $350-500 for the adapters needed for the futofab cv's

    Edited by zKars

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now