Jump to content


Ignition troubles :)

Recommended Posts

Hi all

Now that I've removed the faulty immobiliser the car will crank easily, however I still am having trouble starting it. Appreciate any advice!

After cleaning and regapping the spark plugs yesterday I was able to start and drive it, however it stuttered and carbs backfired a bit. Today I can't get it going again.

After attempts to start, it does smell like unburnt fuel so I think fuel is being provided, but not so sure about spark.

Car has a Pertronix electronic ignition system installed.

I have so far:

- Checked voltage at battery - 12.5V

- Removed the red Ignitor wire from the coil positive terminal and connected a jumper wire from the positive side of the battery directly to the red Ignitor wire. Attempted start - no dice.

- Replaced coil (I have a spare new one) - no dice

One thing I have noticed is that the wiring doesn't seem to match the Pertronix installation instructions. I have 2 wires from both the +ve and -ve terminals of the coil. Also note I have a wire that is leading to nowhere near the distributor!

(As a side note, I seem to have a few electrical gremlins. Windscreen washer doesn't work, wipers dont return to horizontal, tail lights go off when lights switch from parkers to headlights, horns dont work) - all to be fixed in good time! First is getting it started though :)

What I haven't done yet is try measuring the voltage at coil when key is in the 'on' position. I figure this should be 12V as ballast resistor appears to be removed.

Any other ideas though, assuming this is OK?



Link to post
Share on other sites

You really should measure voltage, before going too far. No power, no spark. And the voltage measured will depend more on whether or not the ignition module is passing current, than the ballast resistor.

There is a troubleshooting guide out there about Pertronix modules. It's not very good though. There's actually better troubleshooting info in the installation instructions. You'll need the model number of your module.

Troubleshooting Tips (Ignitor)

PerTronix Instruction Sheets

Link to post
Share on other sites

I found the instructions linked below on the Summit Racing site. They don't exist on the Pertronix site. Good luck. The first test should tell you if the module is working. You might have rotate whole distributor to get the sleeve to move enough in front of the module.

Pertronix doesn't seem to be supporting their older products. You have to wonder about quality control.


Edited by Zed Head
Link to post
Share on other sites

Thanks for that. I have been prodding around today - 3 things

1. The distributor cap wasn't on tightly - one of the clips had broken! Tied it up wiht a cable tie to check if this was hte issue, but no luck.


2. Inside the distributor, it appears that the grounding wire is pretty freyed and old. Could this be the cause? I have to try to find a suitable replacement as I figure it needs to be more flexible than standard insulated wire.


3. In the instructions you've linked to I have hooked up all the wiring and can see 12V - however they say "Rotate the magnet sleeve in front of the module" - however I can't seem to do this. It only budges side to side a smidge.

Link to post
Share on other sites
they say "Rotate the magnet sleeve in front of the module" - however I can't seem to do this. It only budges side to side a smidge.

That's what I meant when I said that you might have to rotate the distributor. Mark the position of the distributor base so that you can get back to it when you're done, loosen the hold-down screw (the one you would loosen for timing), and rotate the whole distributor body. This will move the module in relation to the magnet. If you can see where a magnet is though, you could bump the engine around until it's close, then grab the rotor and twist. you should have about 10 degrees of rotation of the rotor from the mechanical advance. Not much, that's why it's easier to rotate the distributor body.

You could also put the car in gear and roll it back and forth but that wouldn't be very quick and it would be hard to keep an eye on the meter.

Link to post
Share on other sites

Thanks a lot for all your help Zed Head! I ended up taking a step back and deciding to check the spark plugs - pulled a plug and tested it - all was well. However the plug seemed fouled again though so pulled them all and gave a quick once over with a copper brush.

Then it started first time again, easy! A bit hard to keep it alive when cold but pretty normal in my experience. However what isn't normal is the carb backfiring every now and then, even at idle. Idle seems to get slower and slower until it dies. Given last time I left it for 24 hrs it didn't start again, maybe the timing is off?

Link to post
Share on other sites

I decided to look at the fuel aspect of this since I wasn't getting anywhere with electrics. Before checking fuel pressure, wanted to see if fuel was getting into the carbs when accel pressed. Took off the zip-tied filters and tried one - it sprayed. Silly me didn't check all of them, but will have to do that next time. I put some carby cleaner down them and had another go at starting - worked! Voltage at battery when running was 14V.

OK I don't have a timing light yet, but thought I'd fiddle with the timing anyway and see what we could get.

I turned the cap CW to advance it some more and the idle increased (is this normal?). Seemed to run smoother so took it for a drive. No good - possibly worse than before. So I went the other way. It was a bit rough on idle (and even had a backfire then died on me) but driving results are GOOD. Not great, but good. I have no idea what the timing is of course but it's as far back as the adjustment will let me go.

Here's a vid. Sorry it's not very exciting. But you can see how the idle gradually decreases and backfires at 0:42


Is this fixed? DUnno, will see how it starts again when cold. Once started I'm happy to take it to someone who can properly tune it to run at its best.

Link to post
Share on other sites

Idle speed increasing when you advance the timing is normal, as long as it's already in the right range. Without a light though, you're heading down the path of interacting variables. You might be making changes to fix things that aren't really broken, just out of adjustment, leading to more things out if adjustment and a slow spiral to agony. The most common scenario for the Z EFI systems seems to start with adjusting the AFM.

I'm kidding, but most have gone through the process and, after the typical ordeal, they gain a new appreciation for gauges and meters, and start collecting those instead of car parts.

Link to post
Share on other sites

This is probably unrelated, but my engine stalled yesterday, waiting at a traffic light. Motorists were not happy, but a bunch of big guys (off-duty firemen, I think) jumped on the car and pushed it to a nearby parking lot. while waiting for a flatbed, I was checking things, and noticed that there was a loose nut on the distributor junction block (near the coil- mine is a 1978.) we tried to tightened the nut to start the engine, then loosened it until the engine stalled, so we are sure that was the cause.

There were no lock washers on those nuts! installing split-washers were my first thing to do today.. Zed is now happy :)

How did they loosen over the winter?? Those nuts are, I think, the only things I haven't restored or replaced with new un-corroded ones.

I think I will invest in one of those tool rolls this summer. even my small visegrips would have fixed the problem.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.