SeKcGamer

Members
  • Content Count

    173
  • Joined

  • Last visited

Community Reputation

8 Neutral

About SeKcGamer

  • Rank
    Active Member

Social Sites

  • Skype ID
    manny.ortiz12

Contact

  • Map Location
    Houston, TX
  • Occupation
    welder

My Cars

  • Zcars Owned
    280z

Recent Profile Visitors

1,671 profile views
  1. Let me know if you find anything. Then we can go over how much you want for the part and shipping. I’ll give you my phone number.
  2. That’s the thing, no one has the part. I need the federal emission part but there’s plenty of the California model. It’s a 75-76 distributor.
  3. I need a distributor if anyone has one in good condition to sell me.
  4. I’ve also seen many z’s without this
  5. I’ve managed to fix the issue with the efi ground but I’m having trouble finding these in the wiring diagram as far as the one near the ignition coil. And I’m going on a guess that the big housing thing is for vacuum but I don’t know how it’s supposed to be setup. I’ve search on YouTube to see how other cars have it placed. Never found it🤷🏿‍♂️
  6. IMG_4492.mp4 I'm going to work on testing the vacuum, I couldn't find any vacuum test loaner kits or some on sale, I'm just going to have to buy one online. IMG_4492.mp4 IMG_4492.mp4 IMG_4492.mp4 IMG_4492.mp4 IMG_4492.mp4 IMG_4492.mp4
  7. AC3B1A9D-791B-4D15-AA2A-60E59AE1779B.MOV
  8. Reptoid, the car will idle perfectly fine on initial start-up. When you rev the engine to high and the engine shuts off and you try to start it again right after it’ll idle at a lower rpm around 8-900rpm. It usually idles around 1200. And it sounds like it can idle forever. The fuel pressure is reading at 40 , my engine is fuel injected. I don’t know how to test for vacuum but I’m sure you guys could lead me in that direction. I’ll upload a video bright and early in the morning. It’s pretty warm here in Houston but it it’s looking like a constant anytime problem.
  9. well the old igm-04 the car wouldnt turn off, and this new one is the same # as the one I pulled out of the car. is there another ignition module?. Or potentially the module wasn't wired up correctly. ill get pictures.
  10. the fuel pump is an aftermarket fuel pump from autozone that ive had warranty on. ive had a bunch of electrical problems but my highschool teacher sorted some of the many I was having before. I have some wires that I have left alone because I have no idea where they go even at looking at the wiring diagram.
  11. I rev the engine but the tach is the one that shoots up and then the car dies so the tach goes down then the engine shuts off. Once you drive the vehicle if you rev the engine to high it will cause the engine to shut off. It didn't seem to shut off when the rpms were around 2-3k. When I drove the car back I coasted it into the parking lot because it had died. And when I tried to turn the engine it didn't want to start anymore. but when I cranked it the headlights would dim as it cranked. After about 4-5min of waiting I cranked it up and it started for about 5 sec and shut off. ive already rebuilt the engine and fixed my fuel tank the best way. so I'm feeling an electrical end.
  12. After quite a bit of time has passed. I have managed to replace the ignition control module that I previously posted with an lx-512 module and it seemed to be an oem out of box module.myfather installed it for me in Idaho, so you know the car had been sitting for almost a year. My father tried to drive on it but the car would die after he would let off the gas. Car idles great. He towed it to me in texas where I dropped the tank. The fuel still had rust particles floating so I sent the tank and got it re-nu‘d (cleaned and sealed). I installed the renud tank and I got a replacement fuel pump and fuel filter. I fired up the car and she idled great but if you rev the engine over 6-7k the tachometer would do this thing where it goes all the way to redline and down to 0 and the car obviously dies. I don’t know exactly what kind of problem I have now. I will replace the battery because when I try to turn the engine it just cranks but the lights get dimmer when I’m trying to start it. Help
  13. After quite a bit of time has passed. I have managed to replace the ignition control module that I previously posted with an lx-512 module and it seemed to be an oem out of box module.my father installed it for me in Idaho, so you know the car had been sitting for almost a year. My father tried to drive on it but the car would die after he would let off the gas. Car idles great. He towed it to me in texas where I dropped the tank. The fuel still had rust particles floating so I sent the tank and got it re-nu‘d (cleaned and sealed). I installed the renud tank and I got a replacement fuel pump and fuel filter. I fired up the car and she idled great but if you rev the engine over 6-7k the tachometer would do this thing where it goes all the way to redline and down to 0 and the car obviously dies. I don’t know exactly what kind of problem I have now. I will replace the battery because when I try to turn the engine it just cranks but the lights get dimmer when I’m trying to start it. Help
  14. 5FF23A65-AAF1-4023-BA5D-316824E9D6A3.MOV
  15. AE80B0BB-509F-42CD-8788-ACFD154BEF8E.MOV AE80B0BB-509F-42CD-8788-ACFD154BEF8E.MOV AE80B0BB-509F-42CD-8788-ACFD154BEF8E.MOV AE80B0BB-509F-42CD-8788-ACFD154BEF8E.MOV AE80B0BB-509F-42CD-8788-ACFD154BEF8E.MOV