Jump to content

steve91tt

Members
  • Posts

    801
  • Joined

  • Last visited

Everything posted by steve91tt

  1. The o-ring is close to the outside of the manifold so the porting does not effect things. Here is a photo of the RTV smear in the notch I'm referring to. Not the neatest job of applying the RTV but at least it got me on the track. I'll tidy it up later. Todd at Wolfe creek racing pointed me at the solution. I think the timing was 75% of the solution. Vacuum leak was the other 25%.
  2. A quick update on my Mikuni issue. I ended up having a small set of vacuum leaks around my carb/manifold o-rings. The o-ring comes quite close to the edge of the outside surface of the canon manifold in one spot on every runner. I added a small dab of RTV in that area. I also rechecked the timing and found that it was 5 degrees lower than it should have been! Not sure how it got that way but I fixed it and now she idles fine. I ran a time trial event last week at the local track and it performed flawlessly. Thanks for all the help everyone!
  3. I'm using the stock timing curve because I using this setup on my track car which lives it life between 3000 and 7500 RPM. Solid, stead and reliable 34° of maximum advance is all I care about. If you are looking at the 280Z dizzy you might consider the 75/76 model as it uses a magnetic pickup and when coupled with an MSD box it does not require an extra ignition module as the later model units do. Dave Rebello recommended this setup to me and talked me out of going with a crank trigger system. In his opinion it's the most reliable ignition setup for my application.
  4. I recently swapped out my Mallory distributor for a rebuilt stock dizzy from a 1976 280Z. The stock 1976 unit can be used to directly trigger the magnetic pickup on a MSD box. I've thus far been very happy with the results. Other than the MSD box this system should provide OEM reliability and if you go with the programmable MSD box then you should have the flexibility you are looking for. Not as sexy as as trigger wheel setup but performance should be the same or maybe a little better due to the higher voltage and multiple sparks provided by the MSD box. Just my $0.02.
  5. My 1971 240Z flying around our local track.
  6. I checked the valve lash a couple of months ago. All was good no adjustment needed. AFR is in the 11's at idle. I can't drive the car right now as I took the rear stub axel off this morning to replace a grumbly bearing. Should have it back on the road for a test drive on Wednesday.
  7. I checked the float levels by removing a jet block from each carb. The float levels look normal and even between carbs. I would also expect that if the floats were to blame that pairs of cylinders would misbehave as one float adjustment services two cylinders. I re-torqued all the bolts and the car still backfired. I then started turning the idle mixture screws to richen up the cylinders that were popping and lean out the ones that weren't. With this adjustment the popping/backfiring has stopped. I ended up with the following mixture adjustments per cylinder. 1 = 1.75 turns out 2 = 1.25 turns out 3 = 1.25 turns out 4 = 2.0 turns out 5 = 2.0 turns out 6 = 2.5 turns out I assume that the extra fuel requirements of some cylinders is a function of a specific vacuum leak in that cylinder and potentially carb to cab differences in the idle fuel system. This is a bandaide solution for some underlieing problem(s). The search continues.
  8. I've tried flowing propane, carb cleaner and water around the flanges with the engine running to no effect. I'm not sure how to find the leaks.
  9. I re-tightened the manifold/exhaust bolts last night to no effect. Last night the car was backfiring though 1, 4 and 6. This morning I removed the manifold and exhaust and replaced the gasket with a felpro unit applied dry. I had a new set of exhaust and intake studs laying around so I replaced them while I was there. The car now seems to idle more roughly than it did before the gasket replacement and it pops quite badly though #4 and #6. The backfires are now more intense than they were. I plan to let the car cool and re torque the gasket. Any advice for getting the intake to seal?
  10. I opened up the float chamber to adjust the floats. I used new gaskets when I reassembled them.
  11. Yes and I replaced the o rings with new. The previous owner had done a hack job on the carb side of the intake. The head side is still stock dimensions. This is a photo from before porting the carb side of the intake... 90% done... I didn't take a photo of the finished product but it made for a nice smooth transition from the carb to the plastic spacer to the manifold if you look down the throat of the carb.
  12. I took the carbs off the intake, the intake off the head and I took the top off the float chamber. I smoothed out the transition from the carbs to the manifold. I did not do anything with the head side of the manifold.
  13. Backfiring out of multiple carb throats. I'll have to double check to see if I left some parts on the bench.
  14. I took my Mikuni 44's apart this weekend to gasket match the cannon intake. The car now backfires quite badly out of both the carbs and the tailpipe while idling, downshifting and cruising. The AFR's are 11-12 while backfiring and the car pulls hard at WOT where the AFR is in the 12's . The plugs seem normal, timing looks normal, float bowl levels look normal and compression is 170+/-5 across all cylinders. The engine is a Rebello L30. The carbs have 39mm chokes, 150 fuels, 180 airs and deleted balance tube on the intake. Any advice as to how I should diagnose the problem? Could this be caused by a vacuum leak?
  15. I run a BRUTE POWER / PERFECTION CLUTCH 92016B clutch in both my cars. Cheap and indestructible. I've got +6000 track miles on my Rebello powered track car and it's still going strong. I paid less than $80 for the kit which includes a bearing, bushing, collar and clutch.
  16. If you are running a 6AL I would switch to a stock dizzy out of a 1976 280Z and use it to trigger the magnetic pickup input of the 6AL. I recently switched away from the Unilite to this setup and have been very happy with the results. You will have to find a 1976 mount on ebay but it will give you OEM reliability and it's cheaper than the Unilite.
  17. Could you make some sort of offset male/female threaded standoff for the linkage holes? Kinda like this one... McMaster-Carr but the female end would be offset slightly. This would allow you to rotate the standoffs to get the alignment you need. Just a thought.
  18. I'm in the process of installing BadDog frame rails on my 240Z. Since these are new metal I assume I should seam seal around the edges drill drain holes in the bottoms, prep and paint the outside after welding and oil spray as much of the inside as I can access. Any advice?
  19. Here is a photo of the shaft with the broken piece balancing on top. This photo was taken as it would be in the engine looking down at the distributor end. The shaft turns counter clockwise when the engine is running. I may be wrong but it appears to me that this is the twist I would expect if you held the top of the shaft as it was driven counter clockwise from beneath.
  20. The twist direction is what you would expect if you held the top of the distributor end stationary and twisted the shaft counter clockwise (looking down from the distributor end). When I first removed the distributor from the car it was difficult to turn. I thought the rotor was bound up or the bearings had seized. After removing the broken pieces it now turns easily. I assumed it was the broken parts jamming the shaft against the body of the distributor but as you say, this could be a red herring. I see no evidence that the drive gear is spinning on the shaft. The entire shaft looks to be in very good shape except for the distributor tang. I love a good mystery.
  21. I agree that there are some significant forces at play to twist the shaft tab and I would like to find the root cause and avoid it in the future. I could be wrong but I don't see how the oil pump could be involved as there is no damage to the oil pump end of the shaft. Unless I am missing something, if the oil pump froze it should show damage on the oil pump end not the distributor end. I also have a low oil pressure siren that goes off if my oil pressure drops below 20psi. If I had an intermittent oil pump issue I would expect to hear the siren go off while driving but I have not. I suspect that the advancement tabs fell off some time ago. I have been hearing an intermittent rattling near the front of the engine at idle but I was never able to find the cause. I bet the tabs were rattling around in the bottom of the distributor for the past few months until they finally jammed the distributor shaft.
  22. I considered moving to an electronic ignition but Dave Rebello talked me out of it. He convinced me to go with the magnetic pickup distributor out of a 1975-6 280Z to trigger the MSD 6AL that I already have in the car. Dave considers this to be a very reliable option for racing applications. It also has the advantage of simplicity and period correctness. I picked one up on ebay, with a mount, for $60 shipped. Electronic has the advantage of tunability and timing stability. On a street car this is important but for a track car I only really care about performance between 4000-7500 RPM at WOT. Because the ignition is fully advanced under these condtions all that really matters is the stability of the timing and spark intensity. The stability of the stock 1976 distributor is to be determined but the MSD box should deliver lots of spark.
  23. I spoke to Mallory. They said that they have not heard of issues like this with the advance tabs. The distributor is out of warrantee so if I want it fixed I will have to ship it to them and pay for it to be refurbished. I think I will go a different direction.
  24. Blue, I could be wrong but I think the advance tabs inside the distributor broke off and locked it up which caused the shaft to break. It was difficult to turn the distributor rotor by hand after I removed it from the car until I took the distributor apart and removed the broken advance tabs. It now turns easily.
  25. My car stalled in the pits while at the track this weekend. When I starting taking things apart to figure out the cause I was very surprised to find that the oil pump shaft was sheared at the distributor end. Turns out that the advance tabs in my Mallory Unilite distributor broke off and jammed the mechanism causing the distributor to seize. Anyone seen this before?
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.