Jump to content

Chris'sZ

Members
  • Content Count

    57
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Chris'sZ

  • Rank
    Registered User

Contact

  • Map Location
    Tres Ritos, New Mexico
  • Occupation
    Retired Paramedic

My Cars

  • About my Cars
    Great body with the exception of the usual rust areas behind the tires, which I am currently inprocess of fixing. Re-built injected engine. 95% primed and looking for a paint color.
  1. These are "Western" wheels. I have them on my '76 and they do look good... I have seen very few in pictures on this site of them...Good Luck!!! Chris...
  2. Just checking with you 'cause my '76 280 has not started since a mechanic friend of mine took off the positive battery cable to check the alternator... I'm getting spark thru the plugs, but for some reason the injectors are not pushing fuel??? Thusly...I'm frustated like You!!! Any thoughts??? Thanx, Chris...
  3. I'm curious as to which Z this happened to. Does it turn over at all with a new Battery? And what do you think caused the old battery to blow??? Thanx, Chris...
  4. Curious...How do you check the fuel injection relay??? I've checked all my manuals and really got confused... Thanx, Chris
  5. Sorry Mike but what is the VR world second life??? Chris...
  6. Check in your community forum...I found a chart for my '76 280 somewhere in there... Good Luck, Chris
  7. I'm no mechanic but, it possibly could be in the combo switch on the steering colume, you know like where the wipers and lights turn on??? Maybe. Good lucki, Chris
  8. Looks like a heck of a deal to me. I would ask more than that for my '76 280. wish I lived closer and I'd pick her up!!! Good Luck, Chris
  9. Northern New Mexico mountains. My '76 just Loves the mountain curvy roads. I am about 30 miles from Taos and there are 3 that I have seen around. Chris
  10. Hey Tony, I would prefer the recover but due to cost I will probably have to go with the cap...on my '76 Chris
  11. Thanks John. It is behind the kick panel on the left side. Chris
  12. Welp...After useing the Factory Manual and the EFI "Bible"...It appears that I have blown part of the ECU (electronic control unit). In my neck of the woods, I can't find any junk yard Z's to get one. Does any body out there have a spare or know where I can possibly order one from??? Thanks for all of your help prior... Chris
  13. So I've done all the testing I can by useing the service manual and the EFI "Bible" and have determined that I have blown the EGU (electric control unit) Have been unable to find any junk yard Z's in my neck of the woods. I'm assuming that that would work if I could find one. I can only imagine what the dealer would ask...Does any body out there have an extra??? Thanks for bearing with me on this post... Chris
  14. Thanks for the tip. Mine are slow also so as soon as I get her running again I'll put that at the top of my to-do list. Chris
  15. Thanks John. I'm reading the EFI "Bible" which I think will be very helpful. It rained here all day so no chance to work on her today. Hopefully tomorrow (today) will be better. Thanks for your reply and I will keep all posted Thanks Again, Chris...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.