Jump to content

IGNORED

KONI Sports for Classic Z's


Recommended Posts

  • 4 months later...

This was a interesting read.  Lots of issues people have had.  I just installed mine and made a video to see if you all think I did this correct based on the posts here and to help future members.   FYI I used the stock gland nuts because the ones supplied with my shocks didn’t work.  Everytime I attempted to toque them down they’d slip.  The threads were clean and no cross threads.  The stock ones worked fine but I only torqued to 70lbs because I was getting nervous about breaking something with any more force.  

 

Link to post
Share on other sites
11 hours ago, Av8ferg said:

FYI I used the stock gland nuts because the ones supplied with my shocks didn’t work.  Everytime I attempted to toque them down they’d slip.

Koni put a lot of effort in to getting those gland nuts made.  Wonder what went wrong.  The gland nut is meant to center the shock body in the tube in addition to clamping it in to the bore of the strut tube.

@KONI Lee @Joseph@TheZStore

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.