Jump to content

jalexquijano

Parking Light Uprgade Harness 15 Amp fuse blowing / Dashboard and Tail lights gone

Recommended Posts

Last night the dashboard instrument lights, parking lights and tail lights on my 72 240z shut down when i turned  the combo switch on. I noticed that the 15 amp fuse inside the fuse holder provided by Dave Irwin Parking light harness kit went south. Replaced it with  another 15 amp and even a 20 amp fuse dashboard lights, tail lights and parking lights came in for 2 seconds and the fuse went out again. I believe the problem resides in the harness upgrade. Last time this happened i removed it from the circuit and connected the stock female and male 6 wire connectors together and all the lights came back. Could there be an issue with the relays provided in the kit? Should i just check the parking light bulbs first and clean for any corrosión before removing the steering colummn cover and making the straight stock connection again? large124652.jpg

Share this post


Link to post
Share on other sites
5 hours ago, jalexquijano said:

Last night the dashboard instrument lights, parking lights and tail lights on my 72 240z shut down when i turned  the combo switch on.

I believe the problem resides in the harness upgrade. Last time this happened i removed it from the circuit and connected the stock female and male 6 wire connectors together and all the lights came back.

Are you sure that you connected it properly?  Didn't nick any wires?

Don't put larger fuses in to fix a short circuit problem.  Find the short and fix it instead.

https://www.datsun-240z-upgrades.net/product-info/

  • Like 2

Share this post


Link to post
Share on other sites

 

6 hours ago, jalexquijano said:

Replaced it with  another 15 amp and even a 20 amp fuse dashboard lights

Never, ever do this. Unless you want to burn you car to the ground!!!

52 minutes ago, Zed Head said:

Are you sure that you connected it properly?  Didn't nick any wires?

Don't put larger fuses in to fix a short circuit problem.  Find the short and fix it instead.

https://www.datsun-240z-upgrades.net/product-info/

Find and fix the problem. I could be in the harness, relays. You just have to be systematic

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Who's Online   13 Members, 0 Anonymous, 66 Guests (See full list)

  • Search Engine Meta Tags:
    classic, z, datsun, 240z, 260z, 280z, zcar, zed, s30, classiczcars.com, 240z.org, fairlady, 240, 260, 280, nissan, 240 z, 260 z, 280 z, zx, turbo, classic z, 280z cars, cars 240z, car forums, datsun, nissan, cars datsun, car club, 280zx, car, nissan zcar, classic z car,performance,300zx, car years, car raced, texas 350z, 300z, 350z, nissan racing , clubs car, zcca, club datsun
×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.