Jump to content


Starter troubles


Recommended Posts

My Z has got some starter woes - basically most of the time it will click and seem to only crank for half a second. If you turn the key off and keep trying, after a few tries it will crank over perfectly fine and start.

Can anyone help with diagnosing this issue? From searching other threads it appears I may need a new starter...

Link to comment
Share on other sites

Is the battery fully charged? could be a low voltage issue.

I'd also check that your ignition switch isn't faulty. Mine had an issue where it if you turned the key all the way cranking would stop, but if you carefully turned the key and stopped turning it any further once cranking started it would continue cranking until you let go when the engine started.

Maybe hook up a remote start button that you often find in tuning/timing kits to the starter to rule out whether its the key switch or a starter/solenoid issue.

Link to comment
Share on other sites

Sounds like dirty battery terminals. I almost bought a new starter for the same symptoms until I remembered to check. It's a common problem, probably more so on the Z's with their poor battery location.

On that topic - I've found that those cheap plastic terminal covers that you see at the auto parts stores really do an excellent job of keeping the terminals clean. There must be a lot of water and dust that land on them when they're left uncovered. Mine used to get dirty within few months, now I haven't touched them in many.

Link to comment
Share on other sites

I had this happen to me, too, and I noticed it was only on hot days when the car had been sitting in the sun or the engine was warm from driving around town. I think the solonoid was getting overheated as I had clean connections and lots of juice. I swapped the starter out for a spare I had and haven't had the problem since!

Link to comment
Share on other sites

All of the suggestions above are good. To help determine which it is try using a remote starter to start the car. If it will start reliably with the remote starter, especially right after failing to start using the ignition switch, it points to high resistance in the wiring going to the ignition switch and then to the starter solenoid. This particular problem is more likely in the '74 and up years with the ammeter shunt and multiple fusible links due to having many more connections that the pre-74 models.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for all the suggestions guys.

1. Checked battery. Good healthy 12.5V. The +ve terminal had electrical tape all over it as some kind of protection. I replaced the terminal anyway as it was looking tired especially next to the -ve which had previously been replaced. Also as @Zed Head recommended, I bought a proper terminal cap to protect it.


2. Checked the battery ground, and cleaned it up anyway. Was ok.

3. Bought a remote-starter kit from online but while waiting for it to arrive found out this trick - remove the ignition wire and use an insulated screwdriver to bridge between that and the power terminal. This effectively closes the loop and will start the ignition. This worked a charm - and showed that its not the starter motor (as suspected since its new).


4. However what this did show was the female spade connector from the ignition was pretty damn dirty. So I replaced this just in case, but it wasn't the issue either.


5. Next up is the switch itself. The keyed ignition is made of two parts - the key barrel and the switch. As @Mr Camouflage suggested, often the little tongue gets bent so the connection isn't quite lined up to where it should be. Didn't seem to be the case for mine. I also had the same problem trying to crank directly from the switch, so it's not the barrel. It must be the switch or the wiring I was thinking...



6. Went down to the Z Shop in Glen Iris and finally got to meet a bit of a lengend in Z circles, Lyndsay. He was very generous with his time and knowledge - and wow what a huge workshop it is. I bought a 2nd hand switch from him and tried it out. No luck unfortunately... so I took a look under the dash.


7. I found this discreet looking black box. Doesn't quite look right - so opened it up and surely not a stock Japanese 70's bit of kit! This is a Dynamco immobiliser.



I'm going to hazzard a guess that this is part of the problem. Now I've just got to work out how to disconnect/bypass it !! :)

Link to comment
Share on other sites


8. I carefully took apart all the electrical tape holding the thing together and tagged all the wires before cutting the immobiliser loose. As you can see it was a bit of a mess under there.


9. No more immobiliser. I was ready to be disappointed - but put the switch and barrel on and tried again with the key to see what would happen. SUCCESS! Cranks without any issue. Problem resolved.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.