Jump to content

IGNORED

New to the ZXcrew!


1980_280zx_mike235

Recommended Posts

So I just recently (yesterday) bought myself my very first Z car. A 1980 Datsun 280zx completely stock. I'm about to do an alt on it in hops to getting it running! She will start with a charged battery then die when charge dies. I was originally told it was lacking the Alt belt but upon inspection the belt was actually there so I presume that would mean the Alt is faulty. is there anything else I should take into consideration and close look at while restoring this? any problem spots or things worth doing for the long run? Unknown miles and while its running there's no weird noises other than an exhaust leak. any help is appreciated!!

Link to comment
Share on other sites


Pictures are good.  Take pictures of the engine bay and folks will most likely report if anything looks to be missing or awry. I have an '80ZX I bought as my 1st Z car back in 2016.  It's been apart and back together several times.  It's a driving project.  After driving it all summer it's off the road again while I install aftermarket EFI to replace the original Bosch FI.  The cars are quite reliable, but are getting old, so things like fuel injection and suspension are potentially a problem area.  But, perhaps you bought a nice one.  I bought an abandoned mess that someone's ex wife piled a bunch of wine boxes on in her garage. 

z.jpg

Link to comment
Share on other sites

 My car is far from perfect, all I currently have are exterior pictures to show damages. And everything on it is as I got it. I'll take engine bay pictures once home from work but structurally it is sound is just exterior damage. But yeah I'll get the engine bay pictures posted here tomorrow and hopefully you guys can help me figure this gem out 

Screenshot_20201019-145050.png

Screenshot_20201019-145054.png

Screenshot_20201019-145057.png

Screenshot_20201019-145101.png

Link to comment
Share on other sites

1 hour ago, 1980_280zx_mike235 said:

So I just recently (yesterday) bought myself my very first Z car. A 1980 Datsun 280zx completely stock. I'm about to do an alt on it in hops to getting it running! She will start with a charged battery then die when charge dies. 

Use a meter and measure voltage at the battery terminals while it's running.  The dying could be a separate problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.