Jump to content
Sign in to follow this  
280z_s30

1975 280Z EFI Problems HELP

Recommended Posts

Hi I'm new to this page and the car only owning it for 2 months. Being 17 and being used to dealing with carburetors. So to the issue it is running rich I have replaced the coolant temp sensor and the 7th injector plug, have adjusted the air/fuel screw also but still getting too much fuel, please help.

Share this post


Link to post
Share on other sites

If you read a few more threads on "running rich" you'll see it recommended often, to measure resistance of the coolant sensor circuit at the ECU. There are several connections along the way that can add resistance. What the ECU sees is what matters.

Download the Electronic Fuel Injection Guide from the first link below. Get a meter, even a simple one will do. Try to find a way to measure fuel pressure. Read the Engine Fuel chapter, especially the first few page, if you want to understand how all of the parts work together. You'll waste a lot of money if you just guess and replace parts.

XenonS130 - S130 Reference

Amazon.com: multimeter

XenonS30

Index of /FSM/280z

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.