Jump to content

IGNORED

Rear Strut Mount Insulator


Recommended Posts


Run a 10x1.25 die over that and see how it cleans up. Lots of lube while you do it, and careful when starting.

I'm not very close, but I have a couple of those tall 280 insulators available if you get stuck. z240@shaw.ca if you need one.

Link to post
Share on other sites

You could also cut new threads a size smaller. But then you'll be the "idiot PO" if you ever sell the car. I would still do it if it was my car. Maybe even use standard thread size for stronger effect.

I think that there's about 5 mm of extra stud when they're installed. You might not need the messed up part.

Link to post
Share on other sites

The threads look pretty stuffed. The PO dun a good job making it useless.

I would run a M8 x 1.5 die over it and buy a set of think machine washers. If you dont have a metric stock and die set you could take it to a machine shop and get them todo it.

Chas

Link to post
Share on other sites

Thanks for the replies!! It's hard to tell by the picture, but the first 5 to 6 threads are pretty much gone. Come to find out it was a SAE nut that was forced on (been finding that same issue all over the car). Guess I'll start off with trying to rethread it, or even try going down to a M8 x 1.5........

I'm not very close, but I have a couple of those tall 280 insulators available if you get stuck. z240@shaw.ca if you need one.

If all else fails....I'll be giving you a shout!!

Thanks

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.