Jump to content

J Shara

Members
  • Content count

    327
  • Joined

  • Last visited

Community Reputation

1 Neutral

1 Follower

About J Shara

  • Rank
    Registered User

Social Contacts

  • Yahoo
    jcs6016@yahoo.com

Contact

  • Map Location
    Maryland

Profile

  • Gender
    Male
  • Occupation
    Holzhauser's Auto Service

My Z Cars

  • About My Cars
    I own two 1973 240 Z's. One i am restoring to stock condition and the other i purchased for 1300 dollars as a parts car. Most of the parts on my parts car are original and in decent shape. I mostly just bought the parts car for the black interior peices because i am changing the exterior color of my project car from white to 905 red, but it came with an all original engine that runs. I plan to modify this engine to race spec.

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. J Shara

    Camshaft advice

    Both ends of the spray bar. Doesn't seem to be clogged either
  2. J Shara

    Camshaft advice

    Just over 1500 I believe.
  3. J Shara

    Camshaft advice

    Gotta give her a bath too
  4. J Shara

    Camshaft advice

    On a side note, just picked up a 79 L28 with matching 5 speed trans lol. Just to have it. 😈 It's an F54 block and a P79 Head. I've heard different things about the P79 head and when I get around to rebuilding/modifying it, I may just buy a different one.
  5. J Shara

    Camshaft advice

    Does the oil flow around the cam tower mounting bolt? It would have to right? And what about the mouse trap springs could they get weak with age and cause a problem?
  6. J Shara

    Camshaft advice

    Cyl 4
  7. J Shara

    Camshaft advice

    Cyl 5
  8. J Shara

    Camshaft advice

    Cyl 6
  9. J Shara

    Camshaft advice

  10. J Shara

    Camshaft advice

    Cyl 3
  11. J Shara

    Camshaft advice

    Cyl 2
  12. J Shara

    Camshaft advice

    This is cyl 2
  13. J Shara

    Camshaft advice

    I am about 25 mins north east of baltimore in harford county. I also removed the oil filter and blew some compressed air back through the cam towers and the end ones had no back flow of air but the middle one did. I could see it go through to the cam main journal bit it felt different from the other towers. I might try and remove the cam and the middle tower and inspect it but at that point I might as well just pull the head 😩. I am gonna order new rocker arms and lash pads, the cam is a given. I wonder if I should get new valve springs as well at least for the affected cylinders, not all the lobes are burnt. This is cyl 1.
  14. J Shara

    Camshaft advice

    OK so I finally had some time to do some more digging on my Z. It has the original externally oiled camshaft that was in the car when I got it. I set the lash to the spec as per the FSM. I run 10w30 in it with one bottle of Lucas oil stabilizer. I have since taken the plugs out and with the valve cover off cranked the hell out of it. And with the spray bar removed as well I get no oil coming out of the cam towers. But the entire time I was running the car, the oil pressure read fine and the engine never knocked or anything. Is it possible that the oil passages in the head alone could be clogged? Also does the center cam tower supply oil for the entire cam?
  15. J Shara

    Camshaft advice

    Hello everyone. It's been awhile since I've signed on, and to be honest it's been awhile since I've touched my old Z. I was running the car all last summer, and it ran great. It had great power, and pulled really strong. I'm running ZTherapy rebuilt SU's which I synced and tuned, pertronix ignitor, and just an MSA 6 to 1 header. I rebuilt the engine but had the head sent out to Mancini machine, where I know they re surfaced it, and I can only assume they checked, repaired, and assembled the head correctly, as this was some years ago. I was driving the car one day and I thought the valve train sounded louder than normal so I preceeded to pop the cover off and check my valve clearances. I found that a few lobes on my cam are black, not shiny like the others. I also noticed that the oil is dark for how new it is. I'm wondering if I ran the valve clearances too tight on these valves and damaged the surface hardening of the cam. I ran Lucas oil stabilizer in this engine when I was driving the car as well. Also used some ethanol fuel treatment in the gastank. Any feed back would be greatly appreciated.
×

Important Information

By using this site, you agree to our Terms of Use.