Jump to content
12meese

1980 280zx Fuel Pump won't shut off.

Recommended Posts

I have a 1980 280zx and it when I put the key in to on position, the fuel pump turns on and floods the engine with gas, causing the engine to lock in place. Any idea of what might be causing that?

Share this post


Link to post
Share on other sites

That's not a fuel pump problem it's an injector or cold start valve problem.  One of those is stuck open.  The pump should be able to run continuously without flooding the engine.

Could be the ECU or it could be a short circuit on the injector wiring.

How long have you had it?

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I replaced the injectors and the cold start valve. So I'm guessing it probably the computer then?

Edited by 12meese

Share this post


Link to post
Share on other sites

Don't guess. Test.  Disconnect all of the injectors and the CSV and see if they still allow fuel through.  Best to do that test with a pressure gauge, or by removing all of them and watching for leaks.

Or disconnect the ECU and see if they leak.

Why did you replace the injectors and CSV?

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Who's Online   1 Member, 0 Anonymous, 203 Guests (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.