fairladyz432

Triple Solex gas fumes after engine shut off

    Recommended Posts

    Ive been trying to park my Z in the garage but after awhile of sitting in the garage, it starts to smell like gas. I did check each carb venturi area and some have fuel sitting while others look dry. Is this normal? im suspecting it might be fuel level adjustment that maybe out of spec (which i never checked since i got them) but im not sure if its that or possibly a leaky part somewhere. did change all the necessary gaskets and seals prior to installation. I mean i do know there will be some gas odor naturally with carbs but not bad enough to fill the entire garage up. I checked the gas tank and lines and don't see any leaks. it just smells near the carbs themselves. Any help will be great.

    Share this post


    Link to post
    Share on other sites

    good to know that fuel shouldn't be in the throats so i'm suspecting the strong fumes are coming from that. Going to check the float levels and see if that's causing the problem. thanks!

    Share this post


    Link to post
    Share on other sites

    Not sure of your fuel pump set up , but I was running an electrical pump on mine . I would shut my fuel off about a block from getting to my house . This empties the float bowls which just vent to the atmosphere sitting in your garage . If they are basically empty - no fuel smell from there . Also - switching to triples usually doesn’t allow for a vent trap systems for the gas tank . How is the gas tank vented ?

    Share this post


    Link to post
    Share on other sites

    I’m running a electric fuel pump as well So that might be a good idea to wire in a kill switch. Currently the gas tank vent line is capped off but I’m working on using the 280z charcoal canister and figuring out how to set up the distributor vac and purge lines but don’t know where they should go since I converted to triple carbs. Any ideas? I was thinking the purge line goes to intake manifold port to remove the gas vapors but unsure where the distributor vac line goes since I no longer have it connected to the original 280z pre throttle body and vacuum nipple on the distributor ( I think the are tee’d) . 

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now