Jump to content

82280zx

1982 Datsun 280zx help

Recommended Posts

Alright so I traded a blaster and a kx 80 (kx was taken apart blaster wasn’t terrible) together worth around 1300 or 1400. The Datsun has nearly no rust at all only spot of rust is on top of the window. No rust anywhere else at all it is pretty clean for a 280. I’m not sure what’s causing these but the trans leaks just a little. Something in the rear clunks if you are not shifting it easy and sometimes does it when you start moving in reverse. And it also sways a little when your driving it. Think anyone would know what that would be? Thanks

 

 

Sent from my iPhone using Classic Zcar Club mobile

Share this post


Link to post
Share on other sites

The clunk is usually the differential mount gone bad.  They're steel and rubber and the rubber wears out so they move around while changing gears.  The transmission leak could be a lot of things.  Best thing to do is put fresh newspaper under the car after driving it, let it sit overnight and see where the drip is coming from.  Could be the rear seal or where the speedo hooks up, the slave cylinder also.  Click on "Blue is now 240260280 replied to a topic".

 

Share this post


Link to post
Share on other sites
8 minutes ago, 82280zx said:

Thank you very much. I’ll have to get under it and check everything out. You know anything about the swaying?


Sent from my iPhone using Classic Zcar Club mobile

My only guess would be old tires?  Maybe fill them to 35psi and see does that help.  Nice looking car too, forgot to mention that earlier. :blink:

Sounds like you got it cheap too and that's always good.

Share this post


Link to post
Share on other sites

 As far as the clunk goes, check your drive line u-joints. The clunk when starting out in reverse makes me suspicious. At what speed do you notice the sway? can you feel it in the steering wheel?

Share this post


Link to post
Share on other sites
6 hours ago, 82280zx said:

Something in the rear clunks if you are not shifting it easy and sometimes does it when you start moving in reverse. And it also sways a little when your driving it

I would check the control arm bushings also.  Seems to fit your symptoms.  The FSM is available in the site's download section.  The picture is from the RA chapter.

http://www.classiczcars.com/files/category/14-280zx/

 

image.png

Share this post


Link to post
Share on other sites

On a side note, one good thing about your car is that the F54 block already has flat top pistons. And depending on build date, has P79/P90 head, which are arguably some of the best ones. Endless debate about all that.

I have an '80ZX I drive regularly, and an '82 with basket case electrics and excessive rust I've pulled the engine/trans out of.

Most of the suspension bushings on both cars are/were in a poor state. Although neither one is in as good a condition as yours.

I have had a hard time finding OEM style rubber bushings, but poly ones seem pretty readily available. MSA has a whole set for about $120 I think.

If your leak turns out to not be where others have mentioned, Transmission seals are pretty cheap, and removing the trans with the car up at least 3 feet isn't too terrible.

Sent from my [device_name] using http://Classic Zcar Club mobile

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.