Jump to content


No! Not the gremlins!


Recommended Posts

(78 280z) Hey guys. I have a bit of a problem. I hooked up my battery to test it, and make sure it still has juice in it, and to make sure all of my lights are working good. I have nothing but the block, and the crank in the car. all of the stuff is out because im rebuilding it, and inspecting the internals. So i plugged in the battery, and checked to see that the lights worked ok. I turned on the headlights, and the passenger light is very dim. When i switch it to brights it goes out completely, but the drivers light goes bright. I though it was just a worn bulb or something. But then i turned the key to the "ON" position. The little killswitch i rigged up to my fuel pump glows for about half a second when its in its on position, but then i hear a click under the pass. seat, and glovebox then the light goes out. So i turned the key to the "START" position, and the starter doesnt turn over, but the Floor temp light goes on, and there is a click under the glovebox again. This is really wierd. I checked my fuseable links, my grounds, and my fuses. What could be wrong? Everything else works totally fine. Both brake lights, both blinkers, and both driving lights. Im stumped! Thanks a bunch guys!

Link to comment
Share on other sites

Ok, i found out what the problem was with the headlight. I was just a bad connection because it had ALLOT of oxidation on it. cleaned it up, and now it works perfectly. As for the starter, i got that to work as well by just jiggling some wires a bit. For some reason the map light works now too! Now, the only problem is that when i turn the key to the on position i hear the click still, under the seat, and under the glove compartment. And, when i hear the click the little light on my fuel pump cut off switch goes out. But, when the key is in the start position the light stays on, and the fuel pump operates perfectly? I took off the pass seat and found that the relay closest to the center console is the one clicking. The one thats clicking under the glovebox is the one that is right in front. The one that is easiest to get to. Could it possibly be a bad ground? Because everything worked fine before i put the interior back in. Who knows, tommorow ill go ahead and mess with it some more.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.