Jump to content

rcb280z

Supporting Member
  • Content Count

    2,390
  • Joined

  • Last visited

  • Days Won

    8

Everything posted by rcb280z

  1. I couldn't locate anything that would be considered a "stop" Cliff was nice enough to send me pics of his 240 and 280 and again I couldn't see any difference between the 2. Hopefully in about 3 months I can report back here if there is a difference after installing what I have. Need to remove some minor dings from the hood first. Either way it looks as if they are interchangeable so there shouldn't be an issue.
  2. Thanks, I'll look at the hinges I have to see if there is anything that resembles a "stop".
  3. I was wondering if that was the case. To bad I don't have an early set to compare it to. I'll pull mine out of the shed and look for said "stops". Assuming the stops would keep it from opening as far as the ones without. I would prefer the ones without. Hmm....
  4. Been a while since I have posted here. Lot of health issues. I do visit it often though. I have been wanting to get rid of the fiberglass cowl induction hood on my 77 280 for quite some time now. Don't know what ever happened to my original one. But, I did find a correct one for my Z. It didn't come with the hood hinges or tension springs. I did however locate a set of hinges with the springs later. I didn't know until just recently that there are 2 different sets of hinges. Looks like they changed mid year, 74.5-78. Anyone know how to tell the difference between the 2 and why the change
  5. Check your fuel filter and fittings for (if you installed one) your inline fuel pressure gauge.
  6. Mikes Z shop in Whittier got good reviews. No experience with them though.
  7. My Honsowetz, "how to restore" book shows the oil slinger and adds an install step. Weird how the "modify" book tells not to install it. Would be good to know why.
  8. Also try popping the hood a little to vent the heat out while you are away from the car and see if that helps. It'll give you an idea of where to go next while trying to diagnose it. The 77 and 78 have louvered hoods to vent the heat. So there must have been an issue in the earlier models.
  9. I have this one by Craftsman and I like it. Makes adjusting the distributor easy.
  10. Thank goodness! I even zoomed in on it and had myself convinced it was a crack.
  11. Not to change the subject but is that a crack in your block (bottom area) near where the tranny bolts to it. Doesn't have anything to do with the leak, just curious.
  12. What ZH said. I experienced the same thing, hit a bump and heard a clunk sound. My TC rod nut (bushing end) on the passenger side backed off for whatever reason. Retorqued and all was good. Hopefully its that simple for you.
  13. Wow, very nice! I just noticed you're missing a wing nut at the rear of the air filter housing.
  14. Zcarsource.com looks like they have them but they want a lot of money for them. And they are used! Check to see if it can be taken apart. Could be a set of contacts that just need to be cleaned. Assuming it is failing and not something else.
  15. Welcome to the club Richie. She is a beautiful 240! We need more pics though. As far as I'm concerned you have landed on the best site there is! The people are friendly and very knowledgeable here. You will learn a lot. Probably the sole reason I still have my Z. Bob
  16. Yes on the Centerforce. Gold is stage 1 and orange/red is stage II
  17. Amen to that. PM me if you need to chat Cliff. I could use it from time to time myself. It's all I'm good for these days.
  18. its working for me and I have windows 10 with chrome browser as well
  19. I was curious of those as well but according to their website they are out of stock. Did you contact them to make sure they have them or will get them?
  20. A toast you , and another, and another, and................
  21. I can't wait to hear how you make out at the smog station. Fingers are crossed.
  22. Hope you are Okay! Oh man that sucks!! Really sorry for you. Hopefully its just worst looking than it is and you're able to use everything. Although that fender doesn't look good. Keep us posted
  23. I also have the e12-80 on my '77 that I found at a junk yard about 3yrs ago, IIRC. But my ignition module was going south was my reason for installing it. I just spent some time on the internet and can't locate a vacuum advance can at all! Can't even offer any advise at this point. I wish you all the luck ensys.
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.