Search the Community

Showing results for tags 'Fuel lines'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Interior
  • Exterior
  • Electrical
  • Engine & Drivetrain
  • Fuel System
  • Exhaust
  • Body & Paint
  • Suspension & Steering
  • Wheels, Tires & Brakes
  • Z News
  • Technical Articles

Forums

  • CAR TALK
    • Z
    • ZX
    • 510
    • 240K Skyline
    • Roadster
    • Fairlady
  • GENRE
    • History
    • Aftermarket
    • Racing
    • Concepts & Rumors
    • Shop Talk
  • MARKETPLACE
    • Vendor Marketplace
    • Classified Ad Forums
    • Garage Businesses
  • CLASSIC ZCAR CLUB
    • Chatterbox
    • Feeds
    • Video Center
    • Regional Talk
    • Club Website
    • Technical Articles
  • NW Arkansas Z Car Club's Discussions
  • Maryland Z Club's Discussions
  • Midwestern Z Club's Z Chat

Calendars

  • Zcar Events and Shows
  • Zcar Club Washington
  • Classic Car Shows

Marker Groups

There are no results to display.

Categories

  • Wiring Diagrams
  • Microfiche
  • Service Documents
  • Brochures
  • Factory Service Manuals
    • 240z
    • 260z
    • 280z
    • 280zx
    • 300zx
  • Manuals
    • Owner Manuals
  • Website Support
  • CAD Files
  • Software Tools
  • Tech Articles

Product Groups

  • Club Merchandise
  • Direct Advertising
  • Club Membership
  • Club Donations

Blogs

There are no results to display.

There are no results to display.

Categories

  • Z Cars
    • 240z
    • 260z
    • 280z
    • 280zx
    • 300zx
    • 350z
    • 370z
  • Other Models
    • 240k
    • 510
    • Skyline
    • Wagon
    • Trucks
    • Roadster
    • Sedan
  • Other Brands
    • Cars
    • Motorcycles
    • Trucks
    • Pets

Categories

  • For Sale
    • Cars for Sale
    • Parts for Sale
  • Want Ads
    • Cars Wanted
    • Parts Wanted
  • Completed Ads

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Real Name


Map Location


Occupation


ZCCA Membership ID


About my Cars


Website


Yahoo


Jabber


Skype ID


Facebook Page


Zcar 1 VIN


Zcar 2 VIN


Zcar 3 VIN


Zcar 4 VIN


Zcar 5 VIN

Found 4 results

  1. I need help finding a supplier for the two 90 deg. elbow fuel lines at the fuel pump for my '75 280Z. One connects the fuel pump to the fuel tank and the other connects fuel pump to the fuel damper.
  2. I just bought 72 240z and there is rust in the gas tank/fuel lines. What is the best way to fix this without replacing the parts, and if i have to replace the parts where can i find them
  3. I filled up with gasoline, drove about 2/10 of a mile home and parked in the garage. I almost immediately noticed gas dripping, and placed a small pot under the drip. The drip appeared to be coming from the small rubber hose that extends from the top of tank to ??? (perhaps the evaporative vent). The braided hose above the rubber hose was dry. Whatever was leaking dripped perhaps a pint, then quit, and nothing since. It looks to me as if there is no way to get to these hoses without dropping the tank. Any advice would be most welcome, as I suppose it's possible. I don't even have a problem. But something was clearly leaking, though I don't know why it would have stopped. I have a stock '75Z by the way. Thanks for any advice. Regards, Kevin
  4. I have a '73 240z, stock. I finally got it to spark (see http://www.classiczcars.com/forums/showthread.php?t=41386), and now I'm trying to get fuel to it. After a month of trying to get it to spark, I may have run all of the fuel through it. I put 5 gallons in the tank and cranked the engine for a good 2 minutes with no success. The fuel filter is dry. I looked in my Haynes and Chilton manuals. Each suggest that the '73 didn't have an electrical pump - only the mechanical pump up front. I crawled under and couldn't find an electrical pump, either. At least not an external one. I took a couple of pictures of what I did see, and I'm a little confused. There are two wires coming out of a module on the tank. I assume these are the fuel-level indicator wires. There are 2 more wires in the bundle that look like they've never been hooked up. (see pictures). Either way, I'm not getting gas to my motor. There hasn't ever been ANY debris in the fuel filter - I don't think its a clogged line. Assuming my fuel lines are dry and I only have the mechanical pump, do I have to prime it somehow? Thanks for the help - I'm really a noob when it comes to this, but I'm really enjoying the education. (My wife is trying to talk me into selling it, she doesn't really believe that I enjoy working on it. Would be an easier sell if it was ACTUALLY RUNNING:angry:).