Jump to content

Search the Community

Showing results for tags 'dead car'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Interior
  • Exterior
  • Electrical
  • Engine & Drivetrain
  • Fuel System
  • Exhaust
  • Body & Paint
  • Suspension & Steering
  • Wheels, Tires & Brakes
  • Z News
  • Technical Articles

Forums

  • CAR TALK
    • Z
    • ZX
    • JDM
    • 510
    • 240K Skyline
    • Roadster
  • GENRE
    • History
    • Aftermarket
    • Racing
    • Concepts & Rumors
    • Shop Talk
  • MARKETPLACE
    • Vendor Marketplace
    • Classified Ad Forums
    • Garage Businesses
  • CLASSIC ZCAR CLUB
    • Chatterbox
    • Feeds
    • Video Center
    • Regional Talk
    • Club Website
    • Technical Articles
  • NW Arkansas Z Car Club's Discussions
  • Maryland Z Club's Discussions
  • Midwestern Z Club's Z Chat

Calendars

  • Zcar Events and Shows
  • Zcar Club Washington
  • Classic Car Shows

Marker Groups

There are no results to display.

Categories

  • Wiring Diagrams
  • Microfiche
  • Service Documents
  • Brochures
  • Factory Service Manuals
    • 240z
    • 260z
    • 280z
    • 280zx
    • 300zx
  • Manuals
    • Owner Manuals
  • Website Support
  • CAD Files
  • Software Tools
  • Tech Articles
  • Club Graphics

Product Groups

  • Club Merchandise
  • Direct Advertising
  • Club Membership
  • Club Donations

Blogs

There are no results to display.

There are no results to display.

Categories

  • Z Cars
    • 240z
    • 260z
    • 280z
    • 280zx
    • 300zx
    • 350z
    • 370z
  • Other Models
    • 240k
    • 510
    • Skyline
    • Wagon
    • Trucks
    • Roadster
    • Sedan
  • Other Brands
    • Cars
    • Motorcycles
    • Trucks
    • Pets

Categories

  • For Sale
    • Cars for Sale
    • Parts for Sale
  • Want Ads
    • Cars Wanted
    • Parts Wanted
  • Completed Ads

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Real Name


Map Location


Occupation


ZCCA Membership ID


About my Cars


Website


Yahoo


Jabber


Skype ID


Facebook Page


Zcar 1 VIN


Zcar 2 VIN


Zcar 3 VIN


Zcar 4 VIN


Zcar 5 VIN

Found 1 result

  1. Just finished a complete engine rebuild on my 1975 Datsun 280z (I named her Bonnie) a few days ago. I've owned Bonnie since 11/1/2015, just 6 months now, and began the rebuild the end of November. When I tried to start it, I have absolutely no power in the car, no lights inside, no headlights, no clicking in the ignition, nothing? Hoping I didn't kill Bonnie. Here is what I've done so far; I've cleaned and checked the battery and terminals, all new terminals. Checked for power from positive, the only power I have is to the starter, no power to the alternator or the ignition. I've checked the grounds, all are good, the two bolted to the frame and the one to the back of the starter. Needless to say, I'm both stumped and frustrated. I can post pics of anything anyone needs, I appreciate your help. P.S.- Bonnie ran very well when I bought her, all lights worked, started every time, no problems. Just a tired engine. Help??!! Troy
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.