Jump to content

jmarwill

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jmarwill

  • Rank
    New Member

Contact

  • Map Location
    Brentwood, TN
  1. Thanks everyone. Lots of great feedback. I look forward to getting this fixed! Sent from my iPad using Tapatalk
  2. Yes- stock air filter. Im not sure about the vent tubing but I’m pretty sure it is stock. Thanks to all for the feedback and ideas Sent from my iPad using Tapatalk
  3. I’m new to this forum and would appreciate any advice you can offer. I have a ‘72 240Z that is pretty much all original. I’ve owned it for about 2 years (my father-in-law was the original owner). I’ve noticed that if I don’t drive it at least every 1-2 weeks, the gas seems to evaporate from the carburetor. The only way I can start it is to put gas directly into the carburetor and the rubber lines leading to the carbs. This is more than just a hard to start carberated engine...there is no fuel in the carburetor or fuel lines and the fuel pump is not bringing gas to the engine when I’m trying to start it. If I drive it once a week, the Z starts up pretty easily. And the Z runs very smoothly when warmed up with plenty of power. Is this normal? Thanks, Jeff Sent from my iPhone using Tapatalk
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.