Jump to content
Sign in to follow this  
Fire604

Speedhut oil/temp senders & stock EFI control unit

Recommended Posts

This is probably a DUMB question but....

I'm replacing all my gauges with Speedhut gauges to include their oil pressure and coolant temp units. I see from the FSM that both of the stock sending units go to the EFI control unit. Also, the new units require the use of their sending units. So...

1. Will the elimination of the stock sending units for oil and temp cause a problem with the fuel EFI control?

2. If I use Speedhut's sending units, which must be of different current and/r resistance than stock, be OK?

3. Do I need to keep the stock senders in place and ADD the new ones just for the gauges? If yes, does anyone have any recommendations on the best way to do so?

Sorry for the multiple questions. I found many related threads but none touched on this issue. Thanks!!

Share this post


Link to post
Share on other sites

I can't believe no one has any input on this. Guys (and gals) that have installed aftermarket gauges and senders, did you eliminate the stock senders or somehow just add the aftermarket ones?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.