Jump to content

Search the Community

Showing results for tags 'wet engine'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Interior
  • Exterior
  • Electrical
  • Engine & Drivetrain
  • Fuel System
  • Exhaust
  • Body & Paint
  • Suspension & Steering
  • Wheels, Tires & Brakes
  • Z News
  • Technical Articles

Categories

  • Zcar Wiki

Categories

  • Business Directory

Forums

  • CAR TALK
    • Z
    • ZX
    • The New Z
    • JDM
    • 510
    • 240K Skyline
    • Roadster
  • GENRE
    • History
    • Aftermarket
    • Racing
    • Concepts & Rumors
    • Shop Talk
  • MARKETPLACE
    • Vendor Marketplace
    • Classified Ad Forums
    • Garage Businesses
  • CLASSIC ZCAR CLUB
    • Chatterbox
    • Feeds
    • Video Center
    • Regional Talk
    • Technical Articles
  • NW Arkansas Z Car Club's Discussions
  • Maryland Z Club's Discussions
  • Midwestern Z Club's Z Chat
  • National Zcar Convention's Discussions
  • National Zcar Convention's Announcements

Calendars

  • Zcar Events and Shows
  • Zcar Club Washington
  • Classic Car Shows
  • National Zcar Convention's Events

Categories

  • Wiring Diagrams
  • Microfiche
  • Service Documents
  • Brochures
  • Factory Service Manuals
    • 240z
    • 260z
    • 280z
    • 280zx
    • 300zx
  • Manuals
    • Owner Manuals
  • Website Support
  • CAD Files
  • Software Tools
  • Tech Articles
  • Club Graphics

Product Groups

  • Club Merchandise
  • Direct Advertising
  • Club Membership
  • Club Donations

Categories

  • Z Cars
    • 240z
    • 260z
    • 280z
    • 280zx
    • 300zx
    • 350z
    • 370z
  • Other Models
    • 240k
    • 510
    • Skyline
    • Wagon
    • Trucks
    • Roadster
    • Sedan
  • Other Brands
    • Cars
    • Motorcycles
    • Trucks
    • Pets

Categories

  • For Sale
    • Cars for Sale
    • Parts for Sale
  • Want Ads
    • Cars Wanted
    • Parts Wanted
  • Completed Ads

Marker Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Real Name


Map Location


Occupation


ZCCA Membership ID


About my Cars


Website


Yahoo


Jabber


Skype ID


Facebook Page


Zcar 1 VIN


Zcar 2 VIN


Zcar 3 VIN


Zcar 4 VIN


Zcar 5 VIN

Found 1 result

  1. On a test drive today after repairing new injector with bad factory crimp, the short hose from thermostat housing line to manifold blew going 80 mph. Instant steam everywhere. I hobbled off the exit and parked ASAP. The temp gauge pegged. The driver side of the engine bay was pretty soaked. After I repaired the hose and got some water in it, it started and got me home but it ran rough all the way. Do you think its running rough because some things are wet or is it possible I did some more serious damage? 77 280Z n2deep
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.