Jump to content

jkeese01

Members
  • Content Count

    64
  • Joined

  • Last visited

Community Reputation

0 Neutral

About jkeese01

  • Rank
    Registered User

Contact

  • Map Location
    Largo, FL

My Cars

  • About my Cars
    2nd owner, purchased 1980. Engine and transmission rebuilt, repainted, new seat covers, replaced all fuel hoses with bio grade hoses, replaced vapor hoses (no fuel smell in cabin now), HyperFlex Master polyurethane kit. Looking for carpet kit that is close to original.
  1. I did the same exact thing on my 1977 280z. Thanks for the video.
  2. Late reply but maybe others can use the information. Take out you tachometer and speedometer. Clamp pliers on the metal rod going into the rheostat. Lightly clamp another plier on the dash cap and slowly turn a little back and forth (while holding the first set of pliers firmly), until you break the glue bond. Apparently Datsun glued the dash cap on. Now you have to remove 3 more screws for things mounted behind the rheostat, push the brackets back, and then you can barely get the rheostat out. Good luck.
  3. On the profile page in MSA, where you enter shipping address, etc., there is a field "Customer Number" which is permanently kept. I've added my membership number there in the format: CZCC- #, and will add it to the Notes on the order. Someone else said you don't see the discount immediately on the invoice, but it shows up on your credit card. I'll see soon if it still works.
  4. Thanks Arne for my membership number. About to order some expensive parts and this will cover the shipping. And great job Mike for the quick change to the site to supply everyone the number. Jim
  5. The membership number is no longer in the URL. Where can we find it now? Thanks, Jim
  6. Hi jcb, Go ahead. I'm looking at some new louvers online now and was hoping to find someone with better pictures than what is posted by the online stores. For used, I'm looking in the Tampa area so I can avoid paying more for shipping than the cost of the louvers. Thanks.
  7. Drove the Z today for the first time after adding the 5k pot. Car seems to run smoother when set at 1k. This mod is simple to build and definitely worth adding.
  8. I've found a few vendors, but their pictures don't show the louvers very well. Travel'n Man's pics show all angles. Wish the vendors had similar pictures.
  9. Beautiful car. Ebay find. Were they new? I'll have to keep watching Ebay.
  10. I've been wanting to buy a set of louvers for my 280z for a long time. Can you post pictures and where you purchased your louvers? Thanks.
  11. Great job with the Clifford alarm enclosure. I modified a 5k pot using the instructions from Atlantic-Z write up and calibrated it with a multimeter. The idle sounds better with it set to 1k. Raining here today, so didn't take it out for a drive. Did you guys adjust the pot based on the sound of the exhaust?
  12. Thanks for the info. and link. Have you or anyone here installed the 1k pot to fine tune the Temp Sensor? Someone seems to have already added a resistor inline on the Temp Sensor. Adding a 1k pot to make this adjustable looks pretty easy and would be interesting to see how well it works.
  13. At idle, the exhaust makes a puffing sound. I'm probably being too critical on this. Car cranks right up and seems to have good power. Never driven any other 280z, so don't have anything to compare what "normal" is.
  14. The Electronic Fuel Injection Book says "The pressure regulator thus maintains a constant balance between fuel and manifold pressure keeping the difference between them at 36 psi." So if you remove the vacuum, it should show 36 psi, difference with no vacuum is + 36 psi. With my vacuum of 19, I'd think the pressure would be 55 - 19 = effective pressure of 36 psi.
  15. New on fuel system: - Fuel Hoses - Vapor Hoses - Pressure Regulator - Fuel Pump - Clean tank - Rebuilt injectors Vacuum is 19. When driving the car, the fuel pressure will increase to 36 psi at full throttle. It is 28 psi when idling and sounds like it's running lean. Pinching the return fuel hose to the tank increases the fuel pressure to 52 psi. Removing the vacuum hose to the Pressure Regulator ups the pressure to 36 psi. Also ran the car out of a gallon gas tank and still 28 psi idle. Factory Service Manual says it should be 36 psi. Any ideas on getting it to 36 psi? Thanks.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.