Jump to content
Sign in to follow this  
taggedd

Deal Cyl. - '83 280zx

    Recommended Posts

    Got what seems to be a dead cyl. in my 83. I checked my Haynes manual and the firing order seems off. I have replaced plug wires, distributor cap, button, plugs. Still seems dead.

    Thoughts?

    Thanks.

    Tim.

    Share this post


    Link to post
    Share on other sites

    Blocked injector, No pulse, Vacum leak, No compressio, No spark

    I would check the pulse first with a led light in the end of the connection. Next would be spark, Compression then tackle the fuel injector if thats the problem :)

    Share this post


    Link to post
    Share on other sites

    You might try pulling the valve cover an checking to see if one of the rockers has slipped of the valve. When I purchased my 78 in 1997 the PO thought it needed a valve job and it turned out to be that.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    Sign in to follow this  

    ×
    ×
    • Create New...

    Important Information

    By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.