Jump to content

IGNORED

Wiper Mechanical Failure


Recommended Posts

Recently, I have noticed a decline in the movement of my passenger side windshield wiper.  I had time to investigate it today, and found the source of the problem.  The passenger pivot arm that connects to the linkage was slipping and not allowing the wiper to sweep more than a few degrees.  After getting access and removing the pivot assembly, I discovered the two welds that connect the shaft to the pivot arm were broken.  There is also a spline on that end of the shaft, but had worn, probably sometime after the welds failed allowing the shaft to slip.

Cleaned it all up, welded the shaft / arm, lubed and cleaned up both driver & passenger sides, the entire mechanism,  all is well in the wipe world again.   😊

Wiper 1.jpg

Before repair of the 2 welds seen below

Wiper 2.jpg

  • Like 3
Link to comment
Share on other sites

29 minutes ago, siteunseen said:

My older sister got me to eat a brown colored Crayon, said it was chocolate. I hadn't had a good clean wipe since 1973. 

 

Too bad she didn't follow that with an eraser and tell you it was bubble gum.  Could have solved a lot of cleaning problems. 😎

  • Like 2
  • Haha 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.