Jump to content
dawg7

Chasis Dyno Results 3.1 Stroker And Weber Dcoe 40

Recommended Posts

I am posting this information for reference only.  I already sold the Weber carbs with manifold and will be going either Z therapy SUs or Arizona Z 4 Barrel setup.  The reason for selling?  Just didn't have the skill or motivation to get educated on tuning the Webers.  Still up in the air on getting the Top end racing TWM throttle body system.   Kinda pricey at 3k minus the ECM.  Once I get one of those installed I will get back on the dyno. I think the carbs, canon manifold and the mild porting limited the HP.

Did a few chassis dyno runs last month and here is the best pull.   182HP and 189 TQ at max pull at 5800.  I also have an O2 wideband installed.  The AFR was 13.4 at an idle, 12.0 around 3500 and 11.1 at 5800.

The stroker engine is made up from this setup:

N42 block overbore 3mm
KA24E PISTONS ITM RY6660 CUT .5mm by machine shop
N42 head midly ported and polished; gasket matched
Cosmetic head gasket 1.2mm
Isky  L480 cam 480 lift 280 duration
71 240z connecting rods
MSA 6--1 header
2 ½ “ Magnaflow exhaust
Canon Intake
1979 280zx distributor  welded to 15 degree max advance(15 idle to 30 @ 3500 rpm).  Vacuum plugged.
MSD 6AL and MSD tach adapter
3 ohm Petronix flamethrower
Taylor 8mm spark plug wires

Weber DCOE 40-18 settings.

CHOKE                 34
AIR CORRECTION   180
MAIN JET             140
IDLE JET              50F9
EMULSION            F11
AUX VENT            4.5
PUMP JET            1.75
NEEDLE SEAT       1.75
INLET VALVE       .55

post-21697-0-04546600-1425937538_thumb.j

Edited by dawg7

Share this post


Link to post
Share on other sites

Nice numbers. I'm figuring the 42 head had no combustion work- reshaping.

afrs were kind of piggy at higher rpm. You might have lost some HP there.

I'm guessing timing was limited by knock?

Edited by madkaw

Share this post


Link to post
Share on other sites

And you have your numbers reversed. I thought a stroker would have more torque than hp

Share this post


Link to post
Share on other sites

Definitely the engine knocked at 32 degrees.  The idle was best at 17 degrees and only a mix of 100 octane and 93 (40/60 mix) would allow anything higher. The first weld ended up at 15 degrees and I stuck with that for the dyno run.   Might have put another weld on the dizzy and go with a 13 degree travel.  But I knew I was selling the Webers.  And the head was only gasket matched, nothing fancy. 

 

Snappy?  I sure enjoyed the torque but I thought the cam would go higher than 5800.

 

Reversed numbers?  The dyno shop put the lead on the coil as he couldn't get a reading from the plug wire.  Not sure if that affected the readings?

Edited by dawg7

Share this post


Link to post
Share on other sites

Thank you for sharing this information. I hope to get a couple baseline dyno runs this summer.

Share this post


Link to post
Share on other sites

You posted 189 hp when the dyno sheet showed 189 torque(reversed).

I agree that the cam should have allowed good hp all the way to 6500rpm. You might have been drowning in fuel too.

Did you degree the cam?

All the reading I've done on these motors I would say the 42 head was your limiting factor. No quench head.

Share this post


Link to post
Share on other sites

Its water under the bridge so I did not want to bring up however since it has, it looks like the fuel level was too high and caused the mid band (cruise) and high RPM to be too rich. There is not much you can do to tune it out except lower fuel level or change emulsion tubes. I did the same thing at 25mm down. 27-29 looks like it should work better.

Share this post


Link to post
Share on other sites

Yes, I entered the numbers incorrectly.  I edited the first post to reflect the correct numberts which are 182 HP and 189 TQ.

Share this post


Link to post
Share on other sites

That setup needs at least a 10.5 compression ratio,  Your ignition advance should have been closer to 36 - 38 total  at idle you should have been around 12 deg  and main jet seems small for that cam, if it smelled real rich it was probably so lean it was not firing...I was running similar cam carb ##'s   the cam ###'s were at 0.050"? or is that the advertised spec?  I never dyno my car but it was running 10.02 quarter miles      weight vs 1/4 mile times   I calculate I was about 620 hp.....although  I had MUCH MORE into it....  O ringed Block and good old 150hp NOS shot    Too bad I never saw this post way back when you wrote it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.