Jump to content

IGNORED

'71 240z shuts off when lights turn on


austinnelson117

Recommended Posts

Hey everybody, so recently my 240 will shut off instantly when I turn on the lights and the battery is disconnected. They work with the battery connected but since they are running off the battery it sucks it dry. It just started doing this recently. I took the alternator to autozone its good. Battery reading 14 volts with car on. Other recent quirks, liscense plate lights come on with brake lights, and blinkers not working with lights on. Any ideas?

Link to comment
Share on other sites

Sounds like a bad ground/earth somewhere.

I agree. Download the 71 FSM Supplement from Xenons30.com and look at the wiring diagrams. Start around the steering column. While you're at it, buy the headlight relay kit & parking relay kit from Dave Irwin, aka Zsondabrain. Those kits will help prevent similar problems in the future.

Link to comment
Share on other sites

Well, the path to ground for your headlights run through your turn signal switch. Vibration from driving can cause a loose wire to move. Yeah, start with finding the grounds for your headlights and moving toward your turn signal switch. By the way, Dave also has refurbished plenty of turn signal switches and combo switches, too.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.