Jump to content

IGNORED

valve cover vent quastion


jiman

Recommended Posts

Where is the valve cover vent hose supposed to connect to on a 75 280z? when I got the car there was just a hose coming off of the valve cover which went over the intake manifold and just made a 90 degree and went down to nothing. I saw some pictures where it looks like it goes to a port on the afm to tb hose but mine does not have that port. there is a metal tee with a cap on the port that points to the valve cover vent tube, should it connect there?

Link to comment
Share on other sites

  • 3 months later...

Question for anyone here. Attached is a picture of my current setup on my 77 280Z. I got it this way from the PO so I'm not sure what the deal is. I'm looking at the FSM and comparing it with this thread and my car. My car is the one that's different here. I'm wondering if the vent hose that is plugged into the Valve cover, running to the AFM to Throttle Body boot is correct. I replaced the boot, so I know some vehicles had this setup as my old boot had this same valve cover elbow and the previous hose was hooked up there. Is this something that just some owners changed, or was it factory?

post-24025-14150814461964_thumb.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   1 Member, 0 Anonymous, 22 Guests (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy and Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.