Jump to content

RRR007280Z

Members
  • Content count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About RRR007280Z

  • Rank
    Active Member

Contact

  • Map Location
    New York
  1. Running Rich After Headers and new Exhaust installed

    Thanks for all the info, I have a lot to digest. I'll post updates. Sent from my iPhone using Classic Zcar Club mobile
  2. Running Rich After Headers and new Exhaust installed

    Mileage is noticeably lower but can't quantify. I don't smell anything either. I'm trying to research so I can make educated suggestions when I bring it in next time for inspection and annual check up in May. It's making me nuts and staining the left rear of the car, brake light lens etc... it can't be good for the engine either I would imagine. Thanks for your help feel free to reach out if you think of anything. Sent from my iPhone using Classic Zcar Club mobile
  3. Running Rich After Headers and new Exhaust installed

    I wish it were but it's definitely different and I had the same exhaust system without the header before. Only reason I got the header is because it was faster to get than the stock manifold. The outside of my exhaust pipe, inside too, is covered in black soot. Never had that before. Thanks I'll keep looking around and reading what I can. Sent from my iPhone using Classic Zcar Club mobile
  4. Running Rich After Headers and new Exhaust installed

    Thanks, I will definitely bring these things to his attention, hope to get to the root of the problem soon, my mileage is suffering and I don't want the back of my car to be stained. Not to mention that for the first time in 20 years I wonder it it would pass inspection for emissions. Thanks again. Sent from my iPhone using Classic Zcar Club mobile
  5. Running Rich After Headers and new Exhaust installed

    Yes Sent from my iPhone using Classic Zcar Club mobile
  6. Running Rich After Headers and new Exhaust installed

    idles very low when cold as well, runs fine, no stalling etc…
  7. Running Rich After Headers and new Exhaust installed

    turns over but not like when I pull it out of the garage.
  8. Running Rich After Headers and new Exhaust installed

    It has a tough time starting in the cold
  9. Running Rich After Headers and new Exhaust installed

    Mechanic says they looked fine last time I was there, after the exhaust installation, I had my fan motor replaced and since I had already mentioned it to him I mentioned it to him again and asked that he check out the plugs to see if they were fouled, so he said he pulled one of the plugs and it looked fine. A pic of the plug? I was just wondering if there are any components that might have to be removed/moved or adjusted in order to install the header and or exhaust. Thanks.
  10. I recently had headers and a new exhaust installed on my late 1977 280Z coupe and since then I have had a carbon like residue on the tailpipe and bumper. I understand this is referred to as running rich, are the two related or is this just a coincidence. I am not mechanically inclined and do not have the luxury of a garage that I can use to work on my car so I was wondering if there might be something my mechanic did when installing the exhaust system and header that would have caused this condition. He's a great guy and I am not looking to blame him or anything but I want it fixed and was hoping to get any info pertaining to the subject that may be helpful to him when I go back for an inspection. I have read the Cold Start Valve/Thermo Time switch and a couple of other components might be the issue but still wonder if there might be something related to or connected with the header/exhaust installation that might be helpful in resolving this. Thanks for any and all help.
×