Results 1 to 6 of 6

LED Taillight Swap

This is a discussion on LED Taillight Swap within the Electrical (S30) forums, part of the 1st Generation Z (S30) category; I removed the Dave Irwin LED taillights from 721, planning to install in the "new" Z. Brought along the LED ...


  1. #1
    Registered User d240zx2's Avatar
    Member ID
    CZCC-15137
    Join Date
    Sep 2007
    Location
    Houston, Texas
    Age
    70
    Posts
    1,334

    Default LED Taillight Swap

    I removed the Dave Irwin LED taillights from 721, planning to install in the "new" Z. Brought along the LED flasher that worked in 721, too. Guess what? They no workie! The "new" Z is a 10/70 '71. Any thoughts or comments, 'cause I'm stumped?
    First & Third owner of HLS30-00721
    B. 01/70 D. 03/12

    New owner of HLS30-15653
    B. 12/70 D.

    Frank in Houston, Texas

  2. #2
    No more body roll! SteveJ's Avatar
    Member ID
    CZCC-5413
    Join Date
    Dec 2003
    Location
    Gainesville, GA
    Age
    48
    Posts
    3,556

    Default

    Could you have reversed polarity somewhere? LEDs don't like reversed polarity.
    73 240Z
    74 260Z

    Blue's collection of tech tips - A great place to look for answers
    XenonS30 -The cheap source for FSMs
    Georgia Z Club
    Fiddling with Z Cars - Z car tips & tricks and pictures of my car-loving life.
    Steve's CARtography - Just car pictures.

  3. #3
    Registered User d240zx2's Avatar
    Member ID
    CZCC-15137
    Join Date
    Sep 2007
    Location
    Houston, Texas
    Age
    70
    Posts
    1,334

    Default

    I tried both sides of the flasher. Got a buzzer going off with one configuration, nothing with the other. The hazards cause one LED taillight to fully blink, while the other only lights up about a third.
    First & Third owner of HLS30-00721
    B. 01/70 D. 03/12

    New owner of HLS30-15653
    B. 12/70 D.

    Frank in Houston, Texas

  4. #4
    Registered User tlorber's Avatar
    Member ID
    CZCC-20299
    Join Date
    Oct 2009
    Location
    Los Angeles
    Age
    49
    Posts
    1,185

    Default

    Was everything on the "new" car functioning before you attempted the swap? I've found that a bad hazard switch, or one that is not in the correct position can wreak havoc on the turn signal system.

  5. #5
    Registered User d240zx2's Avatar
    Member ID
    CZCC-15137
    Join Date
    Sep 2007
    Location
    Houston, Texas
    Age
    70
    Posts
    1,334

    Default

    Everything worked before I plugged in the LED taillights and flasher and everything works after I changed back. Guess I'll wait 'til Dave gets back from MSA to ask more. Thanks for the thoughts.

    Quote Originally Posted by tlorber View Post
    Was everything on the "new" car functioning before you attempted the swap? I've found that a bad hazard switch, or one that is not in the correct position can wreak havoc on the turn signal system.
    First & Third owner of HLS30-00721
    B. 01/70 D. 03/12

    New owner of HLS30-15653
    B. 12/70 D.

    Frank in Houston, Texas

  6. #6
    Registered User Oiluj's Avatar
    Member ID
    CZCC-15388
    Join Date
    Nov 2007
    Location
    SF Bay Area
    Age
    60
    Posts
    1,727

    Default

    Go back to the basics. First, verify that you get voltage to the tail-light connectors. If you have voltage at the connectors, then just run 12V from the battery to the tail-lights to see what's working and what's not.
    Julio
    1972 240Z (in-progress, 95% complete)
    CZC# 15388

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. taillight restoration
    By george71z in forum Misc (S30)
    Replies: 1
    Last Post: 06-20-2011, 04:36 PM
  2. Taillight swap?
    By Scaotty in forum Body and Paint (S30)
    Replies: 7
    Last Post: 06-02-2010, 06:21 AM
  3. Taillight poll
    By hls30.com in forum Body and Paint (S30)
    Replies: 23
    Last Post: 01-14-2006, 01:34 PM
  4. Taillight panels
    By ricksaia in forum Body and Paint (S30)
    Replies: 7
    Last Post: 12-02-2005, 05:55 PM
  5. Taillight problems!
    By Seanh in forum Electrical (S30)
    Replies: 1
    Last Post: 09-07-2002, 08:54 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88